14/03/2021

Cannot add new Web scraper.

Trying to add a new Open Graph web scraper
Name: OG_ARTICLE Signature : //meta[@property='og:type' and contains(@content, 'image')] Extract Fields: THUMB_URL=//meta[@property='og:image']/@content
The scraper is not saved hitting 'Save' but the other samples disappeared from the list.
Trying to add a new Open Graph web scraper Name: OG_ARTICLE Signature : //meta[@property='og:type' and contains(@content, 'image')] Extract Fields: THUMB_URL=//meta[@property='og:image']/@content The scraper is not saved hitting 'Save' but the other samples disappeared from the list.

-- Cannot add new Web scraper
I just tested it, and it saved. I'd probably need to know a little bit more info to debug. Are you using the default sqlite dbms or are you using mysql or postgres? Any error messages in the DBMS or Apache log files? Another thing you could try (somewhat more risky) is to download the development version of yioop at https://www.seekquarry.com/viewgit/?a=summary&p=yioop and see if it is already fixed.
Best,
Chris
I just tested it, and it saved. I'd probably need to know a little bit more info to debug. Are you using the default sqlite dbms or are you using mysql or postgres? Any error messages in the DBMS or Apache log files? Another thing you could try (somewhat more risky) is to download the development version of yioop at https://www.seekquarry.com/viewgit/?a=summary&p=yioop and see if it is already fixed. Best, Chris

-- Cannot add new Web scraper
I will give it a try with the development version and let you know.
I am using mysql. But I think these are stored in the public_default.db Nothing in the logs.
I will give it a try with the development version and let you know. I am using mysql. But I think these are stored in the public_default.db Nothing in the logs.

-- Cannot add new Web scraper
Okay I tried a development version and a current release. I add my scraper and have it in the list of sample scrapers. Once I change the server settings to mysql the scrapers are all gone and I cannot add new ones.
Okay I tried a development version and a current release. I add my scraper and have it in the list of sample scrapers. Once I change the server settings to mysql the scrapers are all gone and I cannot add new ones.
[X ]